Mark Minasi's Tech Forum
Sign up Calendar Latest Topics

  Author   Comment  

Still Checking the Forum Out
Posts: 3
Reply with quote  #1 
Problem: After synchronizing user files with Sync Center in Windows 7 x64 on an AD network, one or more files will not synchronize.  The error shown in Sync Center is: The request is not supported.  Looking at the SyncLog after checking View, Show Analytic and Debug Logs in Event Viewer, the error is made "clearer" with 0x80070032.

Online search results: Found nothing online that helped.  Nothing.


1) The documents owner would access the files (mostly spreadsheets, but a few were Word documents, PowerPoint presentations, and .PDFs) and they would be slow to open, present error messages, and would either be blank as if they had no content (despite the fact that they were of various sizes and clearly had content), or the files would not open.

2) The document owner could not open the files from the home drive on the server.

3) The document owner could copy the files to his desktop.

4) The document owner would get the same results opening them from the desktop.

5) The document owner could logon from different computers but the results were the same.

6) An administrative user would get similar results opening the documents (errors from the applications), but when copying them, would get the The request is not supported (0x80070032) pop-up message.  The document owner, only got the "The request is not supported" part in the Sync Center.

7) Remote Desktop connecting to the server, an administrative user could copy the document owner's files to the server, and then back down to the document owner's computer file system, anywhere, and then the document owner could then access the files normally.  Therefore this copying process got rid of the problem.

Problem detail: We created a new text document in the document owner's H: home drive and it did synchronize.  Comparing the documents that synchronized with the ones that would not, we found the ones that synchronized had the "A" attribute.  The ones that would not synchronize and were causing this error had the "APL" attributes.  We did this by right-clicking the files, clicking the details tab, and the attributes were listed on that tab.

Cause: Unknown.  Some program must have set the P and L attributes onto these files and that caused them to not open for the document owner.  (We didn't take the time to find out if it were only the P, or only the L attributes, or the combination of both that caused this problem.  We do not know which program might have done this.

Solution: There are probably multiple ways to correct the attributes on files but what we did to remove the PL attributes was to:

1) Copy the files up to the server, then
2) Copy them from there down to the document owner's computer.  (At that point the document owner could use them because the "PL" attributes were removed.)  Then we:
3) Overwrote the owner's documents on his home drive on the server with the copy from the C: drive.
4) Finally, we deleted his Sync Center database and it rebooted.

When he logged on, it synchronized down to the C: drive again without errors.

Conclusions: What A, and P, and L file attributes are in Windows is beyond the scope of this bulletin, though it is important to understand.

When remote connecting to the server, the administrator was likely a Domain admin.  I'm not certain if it was the copying of the files that fixed the problem or if it were the permissions of the administrator on the server that did it.  Apparently if one moves files, the attributes stay, and if one copies the files, they inherit the permissions of the folder they are copied to.  I did not try to copy the files as an administrative user on the workstation, I just tried to open them, so had I copied the files on the affected workstation as an administrative user, that may have also fixed the problem by removing the P and L attributes. 


Grumpy Old Men
Posts: 41
Reply with quote  #2

These may help. you are basically forcing the file to be converted back from the sparse storage format. 

The problem with troubleshooting is that trouble shoots back. ~Author Unknown

Still Checking the Forum Out
Posts: 3
Reply with quote  #3 
Thanks Mafervus.

Senior Member
Posts: 598
Reply with quote  #4 
When I run attrib /? command, on a win 7 machine, I don't see the /P switch.  However the /L switch says:
Work on the attributes of the Symbolic Link versus the target of the Symbolic Link.

I don't know if that has anything to do with your problem but I thought that I would mention it.
Previous Topic | Next Topic

Quick Navigation:

Easily create a Forum Website with Website Toolbox.