Mark Minasi's Tech Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
glenn faustino

Avatar / Picture

New Friend (or an Old Friend who Built a New Account)
Registered:
Posts: 21
Reply with quote  #1 


Hi,

I'm using PowerCLI 6.3 and WMF 5, the moment it throws an error it also kicked me out from the session where I'm currently connected, anyone seen this error?

 

Get-TemplateError.png 



__________________

glenn
C:\> Get-Shell | Where {$_.PipeLine -Contains "Objects"}

 

0
jsclmedave

Administrator
Registered:
Posts: 494
Reply with quote  #2 
Quote:
Originally Posted by glenn faustino


Hi,

I'm using PowerCLI 6.3 and WMF 5, the moment it throws an error it also kicked me out from the session where I'm currently connected, anyone seen this error?

 

Get-TemplateError.png 


__________________
Tim Bolton @jsclmedave
Email: [string](0..20|%{[char][int](32+('527377347976847978324785847679797514357977').substring(($_*2),2))}) -replace ' '  

New to the forum? Please Read this
0
jsclmedave

Administrator
Registered:
Posts: 494
Reply with quote  #3 
I don't have an answer but am curious - 

  1. Are you using the PowerCLI Snap-In or the PowerCLI Module?
  2. What type of Session are you creating?  A session to a vSphere or a CIM session for example...
Just having a hard time following the flow of the screen shot...

If you can explain a little more of what you're trying to accomplish, I would be more than happy to increase my "Thanks! IOU A Dinner And Drink" debt and pass this onto to some people that live and breath in PowerCLI...   [smile]

__________________
Tim Bolton @jsclmedave
Email: [string](0..20|%{[char][int](32+('527377347976847978324785847679797514357977').substring(($_*2),2))}) -replace ' '  

New to the forum? Please Read this
0
glenn faustino

Avatar / Picture

New Friend (or an Old Friend who Built a New Account)
Registered:
Posts: 21
Reply with quote  #4 


1. I'm using PowerCLI modules.
2. Session on System Center Orchestrator server since we need to load 64bit PowerShell 
    because by default Orchestrator only loads 32bit PowerShell and most of the modules
    are designed for 64bit. If we don't initiate a remote session it cannot import the 
    modules.

It only happen when remoting...


Get-TemplateError3.png 

without remoting I can retrieve the property I need:

Untitled.png 



__________________

glenn
C:\> Get-Shell | Where {$_.PipeLine -Contains "Objects"}

 

0
glenn faustino

Avatar / Picture

New Friend (or an Old Friend who Built a New Account)
Registered:
Posts: 21
Reply with quote  #5 
The code on the screenshot are just part of the larger script which is about 800+ lines long, it's composed of various PowerCLI cmdlets but only Get-Template throws that error. The purpose of the script is for VMWare environment discovery like datacenter, datastore, cluster, host, template...etc. The same code is running on PowerCLI 5.5 I think and it doesn't have that error.
__________________

glenn
C:\> Get-Shell | Where {$_.PipeLine -Contains "Objects"}

 

0
jsclmedave

Administrator
Registered:
Posts: 494
Reply with quote  #6 
Quote:
Originally Posted by glenn faustino
The code on the screenshot are just part of the larger script which is about 800+ lines long, it's composed of various PowerCLI cmdlets but only Get-Template throws that error. The purpose of the script is for VMWare environment discovery like datacenter, datastore, cluster, host, template...etc. The same code is running on PowerCLI 5.5 I think and it doesn't have that error.


Glenn, 

Did you see Luc's post on the VMTN PowerCLI forum..?

__________________
Tim Bolton @jsclmedave
Email: [string](0..20|%{[char][int](32+('527377347976847978324785847679797514357977').substring(($_*2),2))}) -replace ' '  

New to the forum? Please Read this
0
glenn faustino

Avatar / Picture

New Friend (or an Old Friend who Built a New Account)
Registered:
Posts: 21
Reply with quote  #7 


Not yet, but he asked me to try a few things but no luck.

https://twitter.com/glenn_faustino/status/743335568340221952

 
By the way, which post in PowerCLI forum are you referring to?


__________________

glenn
C:\> Get-Shell | Where {$_.PipeLine -Contains "Objects"}

 

0
jsclmedave

Administrator
Registered:
Posts: 494
Reply with quote  #8 
Quote:
Originally Posted by glenn faustino


Not yet, but he asked me to try a few things but no luck.

https://twitter.com/glenn_faustino/status/743335568340221952

 
By the way, which post in PowerCLI forum are you referring to?


Correction  He said he was talking to you on Twitter about it and that he never heards the results of something he suggested...

__________________
Tim Bolton @jsclmedave
Email: [string](0..20|%{[char][int](32+('527377347976847978324785847679797514357977').substring(($_*2),2))}) -replace ' '  

New to the forum? Please Read this
0
glenn faustino

Avatar / Picture

New Friend (or an Old Friend who Built a New Account)
Registered:
Posts: 21
Reply with quote  #9 

Sorry, I already replied to him...

__________________

glenn
C:\> Get-Shell | Where {$_.PipeLine -Contains "Objects"}

 

0
jsclmedave

Administrator
Registered:
Posts: 494
Reply with quote  #10 
Did you get it sorted out?  Unfortunately I have not been able to dive into PowerCLI for several months (access removed now as well) so I'm a bit rusty in that area now.
__________________
Tim Bolton @jsclmedave
Email: [string](0..20|%{[char][int](32+('527377347976847978324785847679797514357977').substring(($_*2),2))}) -replace ' '  

New to the forum? Please Read this
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.