Mark Minasi's Tech Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
wavegeek

Still Checking the Forum Out
Registered:
Posts: 1
Reply with quote  #1 

I have an issue where I cannot recreate the path to redirect user desktops(Windows 7) to the following location on one of my file servers: \\poli-server3\Profile$\%username%-desktop. Redirected user desktops then get the folder name "jdoe-desktop" or "jsmith-desktop," etc. I have taken over a server support role from someone who created GPOs in our environment. The path above was added at some point to the GPO(see attachment #1), then it was removed and an alternate path was added to redirect desktops to another location on the server which worked fine. However, we wanted to redirect user's desktops back to the original path above and the GPMC says the path is invalid(see attachment #2)....at one point it was added when the GPO was first created and worked fine. Now we are stuck because we can’t use the original path. In ADUC for example, the %username% variable works for adding user profiles, and when I add the path above to start\run on the user's workstation it brings up the user’s desktop folder in Explorer....but the GPMC doesn't like the path. Any ideas? We are stuck in a corner. One option I have to recover is to restore the original GPO that has the original path \\poli-server3\Profile$\%username%-desktop...this works, but I am trying to figure out why %username%-desktop in the path is invalid when it was obviously added at one point. Also, if I want to move the these directories to a new location in the future I am stuck because I can’t add the "%username%-desktop" variable in the text box to point to a new location.

thanks,

Alex

Attached Images
jpeg attachment_#1.JPG (25.52 KB, 4 views)
jpeg attachment_#2.JPG (63.60 KB, 4 views)

0
gpoguy

Avatar / Picture

New Friend (or an Old Friend who Built a New Account)
Registered:
Posts: 50
Reply with quote  #2 
This may be one of those issues where they changed the UI to block certain "special characters" in later versions of Windows, but in earlier you could enter it just fine. If you're comfortable, you could always try editing the underlying settings files--fdeploy.ini & fdeploy1.ini, within SYSVOL for that GPO, and see if it gets reflected in the UI. You'll find those files under User\Documents & Settings, within that GPO's SYSVOL path. if you edit those files on the PDC emulator DC, that should do the trick. fdeploy.ini is for older XP systems and fdeploy1.ini is for Vista and newer. This is general format of the file so you can see where the path is set highlighted in red below:

[FolderStatus]
My Pictures=2
My Documents=39
[My Pictures]
[My Documents]
s-1-5-21-817735531-4269168403-1409475853-1109=\\SRV1\Marketing\%USERNAME%\My Documents

__________________
Darren Mar-Elia
MS-Group Policy MVP
Founder--SDM Software (https://sdmsoftware.com)
Need Group Policy Training? Check out my Group Policy Fundamentals course: http://pluralsight.com/courses/group-policy-fundamentals
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.