Mark Minasi's Tech Forum
Register Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
wobble_wobble

Avatar / Picture

Associate Troublemaker Apprentice
Registered:
Posts: 832
Reply with quote  #1 
I had 2 RDS Hosts in a load balancing pair hiding behind a RDS Broker + Gateway.

Anyway we have changed the config for different reasons and now only have 1 server left in the collection RDS02.
Servers were configured for User Profile Disks.
One RDS Host is left in the Session Hosts.
We have a new RDS hosts with a different new application, this is not listed in the collection.

Anyway, when someone now logs in they log in twice.
This is causing temp profile issues as well as other issues.
I'd love to understand why I'm getting the two logins.
I suspect it has to do with the initial connection that is then proxied through the gateway to the actual RDS 02 server

Anyone got a fix/ solution or a method of me fixing this.

__________________
Have you tried turning it off and walking away? The next person can fix it!

New to the forum? Read this
0
donoli

Senior Member
Registered:
Posts: 529
Reply with quote  #2 
https://social.technet.microsoft.com/Forums/windowsserver/en-US/f198dccf-4f2d-475f-ba9e-f932f1d42363/remote-desktop-farm-user-logged-in-multiple-times?forum=winserverTS
0
dennis-360ict

New Friend (or an Old Friend who Built a New Account)
Registered:
Posts: 58
Reply with quote  #3 
I think this will be a very hard one to do by forumthread, but lets try. If it doesn't work out im willing to troubleshoot through TEamviewer or the like, no charge and as payback for all your good help here on this forum.

Lets start with the load balancing option, what do you use? Rds lb (the built-in), nlb or kemp? Don't use nlb and if you use kemp, don't use the udp (check our blog 360ict.nl/blog for details).

I assume you use ws12 or higher?

Have you setup to use a single user session on the broker?

What do you mean with logging in twice? On 2 or more rdsh servers? Or on the gateway? Or on the same rdsh?

Do you have the broker on the same machine as the gateway?

__________________
-----
Home is where is sleep
0
wobble_wobble

Avatar / Picture

Associate Troublemaker Apprentice
Registered:
Posts: 832
Reply with quote  #4 
Dennis

Thanks for the offer of help and remote...

Answers as follows:

Load Balancing - RDS LB (the built-in), but I only have 1 server in the collection 
But I have 2 "working servers"
RDS02 which is hosting the published apps and the server that is having the double login issue.
RDS03, not in the collection, not having the double login issue.

I assume you use ws12 or higher? 
Yes, W2012R2, fully patched

Have you setup to use a single user session on the broker? 
Not sure...was looking for that bit, but can't find the config bit for it
Tried to use a GPO to force a single session per user, but it hasn't worked.

What do you mean with logging in twice? On 2 or more rdsh servers? Or on the gateway? Or on the same rdsh? 
So, prior to me removing the 2nd RDS Server from the collection, a user could only log into 1 RDS Server at a time and only had 1 session
Now, on logon through the broker, you get prompted for credentials, then see the RDS Connection info popup, then see a cmd prompt from the RDS Server (not sure why, but noticed that today) and then a RDS session opens, then prompted again, and a second session logs in. When I look at task manager or the connected sessions I see two logged in sessions on RDS02, one active, one disconnected.

Do you have the broker on the same machine as the gateway?
 Yes

Shoot me an email if you want to do a shared session and we can go through it.


__________________
Have you tried turning it off and walking away? The next person can fix it!

New to the forum? Read this
0
dennis-360ict

New Friend (or an Old Friend who Built a New Account)
Registered:
Posts: 58
Reply with quote  #5 
So a remote would be better i think, i msg'd you with my email. Lets keep this thread filled with the outcome or troubleshoot steps.
__________________
-----
Home is where is sleep
0
wobble_wobble

Avatar / Picture

Associate Troublemaker Apprentice
Registered:
Posts: 832
Reply with quote  #6 
Quick update, more notes to follow.

Following a call with Dennis, thanks by the way, I have a solution for my issue.
Hopefully will have a post/ doc I can drop in here soon.

But I was publishing the Session as RemoteApp Programs and not  Remote Desktop





__________________
Have you tried turning it off and walking away? The next person can fix it!

New to the forum? Read this
0
wobble_wobble

Avatar / Picture

Associate Troublemaker Apprentice
Registered:
Posts: 832
Reply with quote  #7 
OK, too lazy and getting busy so I'm posting this in the hope it helps someone else.

Thanks Dennis


 
Attached Files
docx RDS Session Collection Issue.docx (248.69 KB, 7 views)


__________________
Have you tried turning it off and walking away? The next person can fix it!

New to the forum? Read this

0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.